Ξεθάβοντας τρία μικρά Mikrotik RB133..

Ανασκαλεύοντας την αποθήκη μου, βρήκα τρία μικρά Mikrotik RB133, με μερικές κάρτες CM9 (τις θυμάστε;).

Τα πήρα σπίτι και τα χάζευα, μέχρι που μου ήρθε η ιδέα να κάνω το ένα Access Point και να το βάλω στο μπαλκόνι μου. Έχω ήδη ένα TP-Link CPE210, συνδεμένο στον Mikrotik Router μου, για να δίνω δωρεάν internet στην πλατεία που μένω.

Ξεκίνησα να διαβάζω, και είδα πως αυτά έχουν πολύ μικρή και αδύναμη CPU, οπότε μόνον σαν bridge και χωρίς πολλά-πολλά θα μπορούσαν να αποδώσουν αξιοπρεπώς.

Οπότε, πρώτα από όλα, δημιουργούμε το bridge και προσθέτουμε τις 3 ethernet και το wlan1..

/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes comment="" disabled=no \
    forward-delay=15s l2mtu=1518 max-message-age=20s mtu=1500 name=bridge1 priority=0x8000 \
    protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=bridge1 comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=\
    ether1 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge1 comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=\
    ether2 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge1 comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=\
    ether3 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge1 comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=\
    wlan1 path-cost=10 point-to-point=auto priority=0x80
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no

Μετά, πρέπει να βάλουμε το bridge1 να παίρνει ip από τον dhcp server μας.

/ip dhcp-client
add add-default-route=yes comment="" default-route-distance=0 disabled=no interface=bridge1 \
    use-peer-dns=yes use-peer-ntp=yes

Τα ίδια έκανα και στο δεύτερο και για να τα συνδέσω ασύρματα, ακολούθησα αυτόν τον οδηγό:
PTP Links – A Step By Step Guide

Από τη στιγμή που συνδέθηκαν, έκανα κάποιες μικρορυθμίσεις για να βελτιώσω την απόδοση.. Οι ρυθμίσεις απεικονίζονται παρακάτω:

Να πω ότι ενεργοποιώντας το Nstream δεν είχα καλύτερο αποτέλεσμα, οπότε το κράτησα κλειστο. Απλά δήλωσα σαν band τα 5Ghz-Turbo. Υπόψιν πως τα RB133 είχαν licence ως την έκδοση 3.30 και δεν προτίθεμαι να δώσω 40€ για το καθένα για αναβάθμιση 😉

Το αποτέλεσμα; Έβαλα ένα pc που ετρεχε το Btest.exe πίσω απο την διάταξη (PC μου)-(RP133 AP)-(RB133 Client)-(PC).
Σε UDP, είχε ταυτόχρονα 31Mbps send, 16.4Mbps receive. Όχι άσχημα.. Σε send είχε 48.8Mbps. Σε receive δεν μου συνδεόταν…
Σε TCP, είχε ταυτόχρονα 9.3Mbps send, 9.3Mbps receive. Όχι και καλα.. Σε send είχε 14.4Mbps. Σε receive είχε επίσης 14.4Mbps.
Όλα τα παραπάνω με το Bandwidth Test, που έτρεχε ομως πάνω σε υπολογιστές και όχι στα δύσμοιρα RB133..

Στο τέλος, δοκίμασα να μεταφέρω αρχεία, μέσω samba, και το αποτέλεσμα ήταν ενθαρρυντικό…

Τα 4,23 Mbytes/sec είναι καμμιά 40αριά Mbps και για τα RB133 ειναι καλά..

Περιμένω ένα κουτί εξωτερικού χώρου και μερικά πανελάκια, μέσα στις επόμενες μέρες θα βγει μπαλκόνι, με 3 interfaces, τα 2 στα 2.4 και το ενα στα 5, για να καλύψει όλη την πλατεία..

Ίσως να βάλω και καμμιά ip camera στις 2 ethernet που περισσεύουν, για να γίνει σετάκι.. 🙂

Να περιμένετε περισσότερα, μόλις το υλοποιήσω.. 🙂

Προς το παρόν, τα στατιστικά της Πλατείας Αντιγονιδών μπορείτε να τα βλέπετε εδώ:
Webcam & Statistics for twmn::FreeWifi @ Antigonidon Sq. (10.107.1.190)

Leave a Reply

Close Menu